[Ecls-list] build.vc8 files in mac format

Dean O'Connor dean.oconnor at ite.com.au
Fri Feb 9 03:40:38 UTC 2007

Well I guess it must be something at my end, but I tried a fresh 
checkout of CVS numerous times. Possibly a bug in TortoiseCVS on Windows 
XP x64 at work.
Never had such a thing before tho, so very strange.

Anyway, I tried just now on my home XP x32 and don't have the problem.
But I am back to that "long long" error again, using VC8 (VS2005).

If I set HAVE_LONG_LONG to 0 in config-vc8.gc it builds ok.

        echo > msvc-build
        cl -c /nologo -MD /W3 /EHsc /I "." /I ..\..\src\gmp /I 
"..\..\src\gmp\mpn\generic" /D "WIN32" /D "NDEBUG" /D "_LIB" /D "_WIN32" /D
 "_MBCS" /Fompn\generic\rshift.obj ..\..\src\gmp\mpn\generic\rshift.c
..\..\src\gmp\gmp-impl.h(2821) : error C2632: 'long' followed by 'long' 
is illegal
..\..\src\gmp\gmp-impl.h(2822) : error C2632: 'long' followed by 'long' 
is illegal
NMAKE : fatal error U1077: 'cl' : return code '0x2'
NMAKE : fatal error U1077: 'C:\PROGRA~1\MICROS~2\VC98\BIN\NMAKE.EXE' : 
return code '0x2'

Juan Jose Garcia-Ripoll wrote:
> 2007/2/8, Dean O'Connor <dean.oconnor at ite.com.au>:
>> When building msvc version with VC8 (VS2005) from CVS, there seems to be
>> lots of files [in msvc\gmp\build.vc8\...] in Mac format causing compile
>> errors on Windows. [...]
>> "build.vc8\gen-bases\gen-bases.c : error C4335: Mac file format
>> detected: please convert the source file to either DOS or UNIX format"
> I do not understand this. I have not edited these files on any Mac I
> have and I compiled those files without problems in Windows with the
> same compiler (except for the Express version) without any error
> message. How do you retrieve the CVS version?
> Juanjo

More information about the ecl-devel mailing list