[Ecls-list] Compiling on OpenBSD fails

Bruce O'Neel ecl at pckswarms.ch
Thu Feb 8 08:43:27 UTC 2007


Sorry, I don't know at this point.  When I get to work I'll try an x86 with OpenBSD 4 and 0.9i and see what happens.

It might be useful to run gdb on ecl_min and see where it crashes.



----- Message d'origine -----
De: "Mark Voortman" <mark at voortman.name>
Date: Tue, 6 Feb 2007 19:32:53 +0100 (CET)
Sujet: Re: Re: Re: [Ecls-list] Compiling on OpenBSD fails
À: "Bruce O'Neel" <ecl at pckswarms.ch>
Cc: "Juan Jose Garcia-Ripoll" <jjgarcia at users.sourceforge.net>,         ecls-list at lists.sourceforge.net

>> Are you building ecl 0.9i or CVS?  I've only every tried with 0.9i.
>I tried with CVS before, and I just tried with 0.9i and it gave me a
>different error:
>if [ -f CROSS-COMPILER ]; then  ./CROSS-COMPILER compile;  else  ./ecl_min
>compile;  fi
>;*** Lisp core booted ****
>ECL (Embeddable Common Lisp)  65536 pages
>Unrecoverable error:
>Lisp initialization error.
>Abort trap (core dumped)
>*** Error code 134
>Stop in /home/mark/tmp/ecl-0.9i/build (line 71 of Makefile).
>*** Error code 1
>Stop in /home/mark/tmp/ecl-0.9i (line 69 of Makefile).
>> Also I've not tried with threads.  The Boehm-gc needs to be built with
>> threading enabled if ecl is to work with threads.  The one in the
>> ports/packages collection, as  far as I know, is not built that way.
>I'm not building with thread support yet. Let's first get the basics to
>work and then see about threads.

More information about the ecl-devel mailing list