[Ecls-list] Compiling on OpenBSD fails

Mark Voortman mark at voortman.name
Tue Feb 6 18:32:53 UTC 2007


> Are you building ecl 0.9i or CVS?  I've only every tried with 0.9i.

I tried with CVS before, and I just tried with 0.9i and it gave me a
different error:

if [ -f CROSS-COMPILER ]; then  ./CROSS-COMPILER compile;  else  ./ecl_min
compile;  fi
;*** Lisp core booted ****
ECL (Embeddable Common Lisp)  65536 pages

Unrecoverable error:
Lisp initialization error.

Abort trap (core dumped)
*** Error code 134

Stop in /home/mark/tmp/ecl-0.9i/build (line 71 of Makefile).
*** Error code 1

Stop in /home/mark/tmp/ecl-0.9i (line 69 of Makefile).

> Also I've not tried with threads.  The Boehm-gc needs to be built with
> threading enabled if ecl is to work with threads.  The one in the
> ports/packages collection, as  far as I know, is not built that way.

I'm not building with thread support yet. Let's first get the basics to
work and then see about threads.


More information about the ecl-devel mailing list