[Ecls-list] clx, stream-read-sequence

David_Creelman at pa.com.au David_Creelman at pa.com.au
Mon Apr 2 23:44:18 UTC 2007


CLX is working relatively well for me in ECL as long as I don't run some
of the more complicated demos.
If I run ecl and do
(require 'clx)
(load "clx-demos.lisp")

I get the following

> (require 'clx)
;;; Loading #P"/usr/local/lib/ecl/clx.fas"
> (load "clx-demos.lisp")
;;; Loading "/home/davidc/download/ecl/ecl/src/clx/demo/clx-demos.lisp"
> (demos::do-all-demos)
No applicable method for SI:STREAM-READ-SEQUENCE
Broken at EVAL.No restarts available.

However, if I run the clclock demo, I get a clock window as expected,
after doing xhost +.

I've looked through the source for ECL and CLX and I notice that
stream-read-sequence is defined in ext, not si in ECL and that
stream-read-sequence isn't directly called in CLX, so it must be called by
stream-something-I-dont-know-of. I think this is part of the gray streams

Does anyone have any ideas how to get around this one. Where can I find out
how gray streams work ?

Even with this demo problem, I've been able to get at CLX functions and
have a
simple logo like demo app which I could share. Let me know if there is


More information about the ecl-devel mailing list