[Ecls-list] Re: [Ilisp-help] ECLS 0.5

Dr. Edmund Weitz edi at agharta.de
Sun Dec 2 16:59:03 UTC 2001

Martin Atzmueller <martin at atzmueller.net> writes:

> I've attached a fix for all that, such that I'm able to run ILISP
> with ECL now, but it's not a *real* fix, since it requires some
> manual work: you have to _load_ ilisp-pkg.lisp into ECL, compile it,
> and compile cl-ilisp.lisp after that, as well (these files are in
> the ILISP directory, of course :)
> After that, starting ILISP+ECL should work fine.

Thanks, it works now. Note that I had to replace all occurences of
#+ecl by #+ecls, though. IIRC this won't be necessary in the next
version of ECLS due to the merge with ECL.

> > Afterwards Emacs hangs completely and has to be killed. This
> > happens with Emacs 20.7 as well as with 21.1. It happens on the
> > console and under X and with two different Linux
> > installations. ILISP is 5.11 in all cases.
> You should probably get the latest CVS-version from Sourceforge.
> This worked for me.

I don't think this was the problem. My laptop with Emacs 21.1 used a
CVS version of ILISP that was probably three or four weeks old when I
posted my question. My server with Emacs 20.7 used the release
version. Both had the hang problem, and on both machines it's gone
after applying your fix.

Thank you very much,

More information about the ecl-devel mailing list