Test results

Elias Pipping pipping.elias at icloud.com
Tue Sep 13 23:40:48 UTC 2016

> On 13 Sep 2016, at 15:16, Robert Goldman <rpgoldman at sift.net> wrote:
> On 9/13/16 Sep 13 -2:50 AM, Elias Pipping wrote:
>>>>>> - SBCL 1.1.13 now fails plenty of tests (11 to be precise). SBCL 1.3.9 and later are fine(++)
>>>> The last time I checked SBCL 1.3.9 (really a candidate for release), it
>>>> failed because of some pathname-printing code. Passes for me now on Mac
>>>> and Linux.
>> That was a regression that they fixed prior to the 1.3.9 release, fortunately. I just wanted to point out here that so far rather old sbcl releases worked perfectly well and now they don’t. Might be worth investigating what changed.
> Do you have any error logs you could post?  For example to launchpad?
> WRT mkcl, I'm going to let this slide.  I am already tracking it from
> git, which I don't do for most other implementations.x I can't afford
> the complexity of tracking multiple git repositories.  According to the
> page at common-lisp.net, the gitlab repository is the official one, so I
> will stick to that.

I think https://common-lisp.net/project/mkcl/ is outdated in that respect.


is clearly official. Moreover, JCB indicated to me earlier that


is the primary location for bug reports.

> So my understanding of what needs investigation is:
> 1. What's going on with the new Windows failures.
> 2. What's going on with the newly introduced issues on older versions of

It turns out the test3 issue was down to the same problem as the issues with older SBCL releases: I’d run out of space on the machine I was testing on without noticing. So please ignore them entirely. I apologise for the false and confusing reports.

I’ve used this as an occasion to move my testing to another machine as well as make it cleaner and more automatic. The result? I’ve started from the latest git revision of ASDF, which is 7b7b9f0 and ahead of by 3 commits. Consequently, you can find the results of my testing at:

(Yes, I haven’t bothered with a proper name. Not sure how permanent this all is)

This will tell you that
 - 2 tests fail on mkcl-1.1.9-154-1e72d5d, as is already known.
 - 2 tests still fail on the hobbyist edition of lispworks because there’s no way to check if a lispworks installation provides a proper `deliver` function or a dummy (the hobbyistDV edition would pass these tests)

And also that
 - I hacked around the bogus warning that lispworks 6.1.x gives so that on my machine, it passes all tests (on somebody else’s, it wouldn’t)
 - Allegro CL is not yet in there because I have yet to find a way to compute a proper version string that takes patches into account. The version I have passes all tests, though.

All the corresponding logs can be found in the parent directory, which is

In summary, on Linux, the MKCL issue that we already know about, is the sole regression for now.


More information about the asdf-devel mailing list