ASDF is 3.2 release candidate

Faré fahree at
Mon Dec 26 22:34:17 UTC 2016

OK, so apparently:
* make-operation: You need an updated iolib for further tests as this
causes a lot of errors :-(
* make-operation: eco, prove need to use make-operation (sent bug
reports). Many systems use prove.
* the uffi-tests bug is probably due to the update in cffi — dunno
whether it's addressed upstream or not. If not, it needs be reported.
Another package complains about an old uffi, so, maybe try to update
* the failures to locate some .so's might or might not be due to the
CFFI update.
* make-operation: cl-protobufs had the bug, it was fixed already, but
not yet in ql; no system in ql uses it so no need to update for now
but if you do we can check that nothing else breaks.
* make-operation: error in lambda-reader-8bit is my fault. Fixed.
* Warning in uiop is my fault. Fixed.

PS: For redirecting the output of subprocesses, you can't just
redirect a lisp stream; the Lisp process itself must be started with
its outputs properly redirected. You can start the building Lisp
process with e.g. (uiop:run-program (lisp-invocation:lisp-invocation
...) :output my-logfile-pathname :error-output :output :input nil)

—♯ƒ • François-René ÐVB Rideau •Reflection&Cybernethics•
Resentment is like taking poison and waiting for the other person to die.
       — Malachy McCourt

On Mon, Dec 26, 2016 at 3:02 PM, Anton Vodonosov <avodonosov at> wrote:
> Results are coming, these lisps are ready:
>     ccl-1.10-r16196-f96-linux-x86
>     cmu-snapshot-2016-12__21b_unicode_-linux-x86
>     sbcl-1.3.12-linux-x86
> The following report is the part of the diff including only results where new version fails:
> As we can see, other systems than asdf-systems-connections fails with the
> " OPERATION instances must only be created through MAKE-OPERATION." too.
> This error constitures the majority of failures.
> To make it easier seeing other errors, the next report filters out the
> " OPERATION instances must only be created through MAKE-OPERATION."
> and leaves only other errors:
> Notable are the cl-python failure, the "Unknown CFFI type (:STRUCT TUNION1)" error,
> the "Component CLSQL-UFFI-SYSTEM::UFFI does not match version 2.0, required by #<SYSTEM "clsql-uffi">"
> Best regards,
> - Anton
> 26.12.2016, 11:57, "Anton Vodonosov" <avodonosov at>:
>> Tests are running (wht updated slime, cffi, asdf-systems-connections)
>> 26.12.2016, 08:22, "Faré" <fahree at>:
>>>  I see no unexplained failure in Anton's previous test run, but it's
>>>  possible that the explained failures are hiding further failures down
>>>  the line.
>>>  Anton: can you re-run with an updated asdf-systems-connections AND an
>>>  updated SLIME?
>>>  —♯ƒ • François-René ÐVB Rideau •Reflection&Cybernethics•
>>>  Have the courage to take your own thoughts seriously, for they will shape you.
>>>                 — Albert Einstein
>>>  On Mon, Dec 26, 2016 at 12:00 AM, Faré <fahree at> wrote:
>>>>   I see a lot of failures on ECL that seem related to using swank,
>>>>   except the swank package is not defined. That also might be caused by
>>>>   a bad and/or old SLIME, that was badly abusing some asdf internals in
>>>>   an incoherent way. Can you try with the latest SLIME?
>>>>   Note that I am quite angry at the SLIME maintainers because I have
>>>>   tried many times to offer them fixes to swank.asd but they never
>>>>   merged any of my proposed pull requests.
>>>>   Otherwise, it looks mostly good.
>>>>   NB: When there is an error from a gcc subprocess, you don't seem to be
>>>>   capturing the output, which goes directly to fd 1 / fd 2 of the
>>>>   process, as inherited by the subprocess. Maybe you can fix that in
>>>>   cl-test-grid?
>>>>   —♯ƒ • François-René ÐVB Rideau •Reflection&Cybernethics•
>>>>   The idea is not to confront bad ideas but to come up with good ideas.
>>>>   Otherwise, your enemies define the game and you are the loyal opposition.
>>>>          — Terence McKenna
>>>>   On Sun, Dec 25, 2016 at 7:22 PM, Anton Vodonosov <avodonosov at> wrote:
>>>>>   It is the same system.
>>>>>   When previous result was CRASH and new one is FAIL, it might be the same error. But when the previous was OK and new is FAIL, it's more suspicious.
>>>>>   For example:
>>>>>           (LOAD exscribe OK)
>>>>>   vs
>>>>>           (LOAD exscribe FAIL) QUICKLISP-CLIENT:SYSTEM-NOT-FOUND : System "fare-scripts/rescript" not found
>>>>>   26.12.2016, 02:36, "Faré" <fahree at>:
>>>>>>   On Sun, Dec 25, 2016 at 4:08 PM, Anton Vodonosov <avodonosov at> wrote:
>>>>>>   It's not looking too bad, but there are a lot of new failures with the
>>>>>>   latest sbcl, where some dll is not found. Can that be explained by
>>>>>>   your running on a different setup where some libraries are missing, or
>>>>>>   is that something I should investigate?
>>>>>>   —♯ƒ • François-René ÐVB Rideau •Reflection&Cybernethics•
>>>>>>   Language is froth on the surface of thought. — John McCarthyte

More information about the asdf-devel mailing list