[Asdf-devel] package-system

Faré fare at tunes.org
Fri Apr 18 23:13:08 UTC 2014

On Fri, Apr 18, 2014 at 5:09 PM, Robert P. Goldman <rpgoldman at sift.info> wrote:
> Faré wrote:
>> OK, so the main contender seem to be, without -system suffix:
>> one-package-per-file
>> Robert, are you alright with that name?
>> Do you insist on the shorter variant package-per-file ?
>> I can do the renaming this weekend, and update the various relevant libraries.

> I don't care so much about whether or not one- is there.
> But it seems to me that it would be a LOT better if "SYSTEM" appeared
> somewhere in this name.  Even to the point that PPF-SYSTEM would be
> better than PACKAGE-PER-FILE...
> I guess
> )
> isn't terrible, but ONE-PACKAGE-PER-FILE doesn't scream "I am a subclass
> of SYSTEM" to me.  Note for comparison that all of our file subtypes
> have -FILE (like STATIC-FILE, JAVA-FILE, etc.).  That seems like a good
> convention.
On the one hand, I hear your arguments, on the other hand, they are
mitigated by the fact that:
* where there is a :class one-package-per-file, there are usually no
:components being declared,
 and so little opportunity for confusion.
* conversely, parse-component-form since ASDF3 has a guard against
using a subclass of system
 as the class of a subcomponent:
  (when (and parent (subtypep class 'system))
          (error 'non-toplevel-system :parent parent :name name))

That makes the -system suffix less necessary in my eyes,
though I would usually have reacted just as you did,
and in this case, I would drop it for the sake of concision,
especially since one-package-per-file-system might confusingly sound like
a filesystem that has only one package, which is the opposite of it.

I will still wait for comments, but unless a better proposal comes along
and/or Robert vouches for a different name, I will rename package-system to:

—♯ƒ • François-René ÐVB Rideau •Reflection&Cybernethics• http://fare.tunes.org
Love doesn't scale. — Eric S. Raymond

More information about the asdf-devel mailing list