[Asdf-devel] package-system

Robert P. Goldman rpgoldman at sift.info
Fri Apr 18 21:09:58 UTC 2014

Faré wrote:
> OK, so the main contender seem to be, without -system suffix:
> one-package-per-file
> Robert, are you alright with that name?
> Do you insist on the shorter variant package-per-file ?
> I can do the renaming this weekend, and update the various relevant libraries.
> —♯ƒ • François-René ÐVB Rideau •Reflection&Cybernethics• http://fare.tunes.org
> "I'm going to live forever, or die trying!" — Spider Robinson

I don't care so much about whether or not one- is there.

But it seems to me that it would be a LOT better if "SYSTEM" appeared
somewhere in this name.  Even to the point that PPF-SYSTEM would be
better than PACKAGE-PER-FILE...

I guess


isn't terrible, but ONE-PACKAGE-PER-FILE doesn't scream "I am a subclass
of SYSTEM" to me.  Note for comparison that all of our file subtypes
have -FILE (like STATIC-FILE, JAVA-FILE, etc.).  That seems like a good


More information about the asdf-devel mailing list