[armedbear-devel] strange asdf behavior with 0.20.0

Mark Evenson evenson at panix.com
Fri Jun 25 09:21:40 UTC 2010

On 6/10/10 7:13 AM, Mark Evenson wrote:
> On 6/9/10 8:20 PM, Kevin Raison wrote:
>> I just installed 0.20.0 and am now unable to load usocket, yet I can
>> still load cl-ppcre and other Edi-ware. Upon rolling back to 0.19.1,
>> the same usocket package compiles and loads just fine. I have tried
>> using the binary distribution of 0.20.0 as well as building my own, with
>> the same result. There does not seem to be anything wrong with the
>> usocket package definition itself. Has anyone else seen this or know
>> what is going on? Here is the output of 0.20.0:
> […]
> Seemingly a bug in ABCL macro expansion for keyword arguments for which
> a value is NIL with additional arguments in the list.
> For now, if you aren't using SBCL with the same usocket.asd you can
> patch usocket with the attached patch.

Filed as [ticket #101][1].

[1]: http://trac.common-lisp.net/armedbear/ticket/101

"A screaming comes across the sky.  It has happened before, but there
is nothing to compare to it now."

More information about the armedbear-devel mailing list