[armedbear-devel] strange asdf behavior with 0.20.0

Erik Huelsmann ehuels at gmail.com
Fri Jun 25 20:47:00 UTC 2010

Hi Mark, Kevin,

On Fri, Jun 25, 2010 at 11:21 AM, Mark Evenson <evenson at panix.com> wrote:
> On 6/10/10 7:13 AM, Mark Evenson wrote:
>> On 6/9/10 8:20 PM, Kevin Raison wrote:
>>> I just installed 0.20.0 and am now unable to load usocket, yet I can
>>> still load cl-ppcre and other Edi-ware. Upon rolling back to 0.19.1,
>>> the same usocket package compiles and loads just fine. I have tried
>>> using the binary distribution of 0.20.0 as well as building my own, with
>>> the same result. There does not seem to be anything wrong with the
>>> usocket package definition itself. Has anyone else seen this or know
>>> what is going on? Here is the output of 0.20.0:
>> […]
>> Seemingly a bug in ABCL macro expansion for keyword arguments for which
>> a value is NIL with additional arguments in the list.
>> For now, if you aren't using SBCL with the same usocket.asd you can
>> patch usocket with the attached patch.
> […]
> Filed as [ticket #101][1].
> [1]: http://trac.common-lisp.net/armedbear/ticket/101

Thanks for the very nice (and small!) reproduction recipe. It took
quite a bit before I understood what's happening here, but the
regression has been fixed now! (On trunk/ that is.)



More information about the armedbear-devel mailing list