[armedbear-devel] strange asdf behavior with 0.20.0

Mark Evenson evenson.not.org at gmail.com
Thu Jun 10 11:05:21 UTC 2010

On Jun 10, 2010, at 7:13 AM, Mark Evenson wrote:

> On 6/9/10 8:20 PM, Kevin Raison wrote:
>> I just installed 0.20.0 and am now unable to load usocket, yet I can
>> still load cl-ppcre and other Edi-ware.  Upon rolling back to 0.19.1,
>> the same usocket package compiles and loads just fine.  I have tried
>> using the binary distribution of 0.20.0 as well as building my own, with
>> the same result.  There does not seem to be anything wrong with the
>> usocket package definition itself.  Has anyone else seen this or know
>> what is going on?  Here is the output of 0.20.0:
> […]
> Seemingly a bug in ABCL macro expansion for keyword arguments for which a value is NIL with additional arguments in the list.

The [offending changeset was r12693][1],
that being Erik's fix for dispatch macro in Stream.java which returns NIL values.

[1]: http://trac.common-lisp.net/armedbear/changeset/12693

"A screaming comes across the sky.  It has happened before, but there is nothing to compare to it now."

More information about the armedbear-devel mailing list