[slime-devel] SLIME-Clisp Unicode encoding

mv968 mv968 at tiscalinet.it
Wed Mar 16 10:29:17 UTC 2011

It worked, thank you very much. Nevertheless, it was quite problematic 
solving such a basic issue. I also tried CCL changing my emacs to

(set-language-environment "utf-8")
(setq inferior-lisp-program "c:/home/bin/ccl/wx86cl64 -K utf-8")
(require 'slime)
(setq slime-net-coding-system 'utf-8-unix)
(slime-setup '(slime-fancy))

but, without your last hack, I had the same #\à - CP1252 issue.

Also I see something strange in SLIME startup messages with CCL, that 
make me suspect that SLIME is still using CLISP instead of CCL:

;; Loading file 
C:\home\me\.slime\fasl\2010-12-10\clisp-2.49-win32-pc386\swank-clisp.fas ...
WARNING: DEFUN/DEFMACRO: redefining function BREAK in
C:\home\me\.slime\fasl\2010-12-10\clisp-2.49-win32-pc386\swank-clisp.fas, was 
defined in
WARNING: Replacing method #<STANDARD-METHOD (#<BUILT-IN-CLASS T>)> in 
;; Loaded file 

Thanks again.


Il 16/03/2011 07:53, Helmut Eller ha scritto:
> Hmm, this is a bit awkward to fix.  We need to set the encoding
> before Slime starts.  It should work to add
> (setf (stream-external-format *standard-input*)
>        (ext:make-encoding :charset "utf-8"))
> to the file ~/.swank.lisp.
> Helmut
> _______________________________________________
> slime-devel site list
> slime-devel at common-lisp.net
> http://common-lisp.net/mailman/listinfo/slime-devel

More information about the slime-devel mailing list