[parenscript-devel] with-timeout

Vladimir Sedach vsedach at gmail.com
Wed Jun 20 22:29:35 UTC 2007

Good point. On the one hand, do-after-delay is the logical name for
it. On the other, I think the name of the Javascript function should
be preserved somehow since that way there will be less cognitive
dissonance, and there would be one less barrier to entry for new
users. How does do-set-timeout sound?

I have to run soon, so I'll add ignore-errors sometime tomorrow.


On 6/19/07, John Fremlin <john at fremlin.org> wrote:
> About this
> (defjsmacro with-timeout ((timeout) &body body)
>   `(set-timeout (lambda () , at body) ,timeout))
> I wonder if with-timeout is really the best name for it? I mean
> something like do-after-delay would make more sense.
> PS. Here's another one
> (defjsmacro ignore-errors (&body body)
>   `(try (progn , at body) (:catch (e))))
> [...]

More information about the parenscript-devel mailing list