segfault while testing lil

Daniel Kochmański daniel at
Thu Apr 14 14:01:50 UTC 2016

In fact I did, but it didn't work, so I've tried the testcase you
provided with the same result, so I've wrote an e-mail.

I had to manually quickload the reader-interception, because it's not
listed in the lil/test dependencies. I think it's a lil's test system
definition bug.

Either way, testing the system gives the segmentation-violation just as
you said, so the bug is confirmed. I think that it's triggered by
something in hu.dwim.stefil (hu.dwim.* already proven a few ECL bugs).

Could you add it to the issue tracker on ?


Faré writes:

> On Thu, Apr 14, 2016 at 1:28 AM, Daniel Kochmański <daniel at> wrote:
>> Hey,
>> I have on this testcase:
>> jack at pandora ~ % rlwrap ecl -eval "'(#.(require \"asdf\")#.(asdf:test-system :lil))"
>> ;;; Loading "/home/jack/quicklisp/setup.lisp"
>> ;;; Loading #P"/usr/local/lib/ecl-16.1.2/asdf.fas"
>> An error occurred during initialization:
>> Component "reader-interception" not found, required by
>> #<package-inferred-system "lil/test/base">.
> That's just you missing a dependency.  Install all dependencies, or
> try loading quicklisp instead of requiring asdf.
> —♯ƒ • François-René ÐVB Rideau •Reflection&Cybernethics•
> Thinking is the hardest work there is, which is probably the reason why
> so few engage in it. — Henry Ford

Daniel Kochmański ;; aka jackdaniel | Poznań, Poland
TurtleWare - Daniel Kochmański      |

"Be the change that you wish to see in the world." - Mahatma Gandhi

More information about the ecl-devel mailing list