[Ecls-list] Mingw users here?

Matic Kukovec matic.kukovec at pametnidom.si
Thu Aug 8 18:34:31 UTC 2013

Hi Juanjo,

I have a Windows Vista 64-bit, tried compiling a fresh git clone of ECL 
in the MinGW32 shell.
"./configure" works, but "make" gives me an error:
         make[1]: *** No rule to make target 
'/home/Matic/ecl/src/util/gdbinit', needed by '.gdbinit'.  Stop.
         make[1]: Leaving directory 'C:/MinGW/msys/1.0/home/Matic/ecl/build'
         Makefile:70: recipe for target 'all' failed
         make: *** [all] Error 2

Also tried Cygwin.
"./configure" worked, "make" failed with:
         gcc -c -DHAVE_CONFIG_H -I. -I/home/Matic/ecl/src/gmp/mpn -I.. 
-D__GMP_WITHIN_GM          P -I/home/Matic/ecl/src/gmp 
-DOPERATION_dive_1 -g -O2 tmp-dive_1.s -DPIC -o  dive _1.o
/usr/lib/gcc/i686-pc-cygwin/4.5.3/../../../../i686-pc-cygwin/bin/as: BFD 
(GNU Binutils) assertion fail 
         tmp-dive_1.s: Assembler messages:
         tmp-dive_1.s:110: Error: cannot represent relocation type 
         Makefile:819: recipe for target `dive_1.lo' failed
         make[4]: *** [dive_1.lo] Error 1
         make[4]: Leaving directory `/home/Matic/ecl/build/gmp/mpn'
         Makefile:914: recipe for target `install-recursive' failed
         make[3]: *** [install-recursive] Error 1
         make[3]: Leaving directory `/home/Matic/ecl/build/gmp'
         Makefile:1180: recipe for target `install' failed
         make[2]: *** [install] Error 2
         make[2]: Leaving directory `/home/Matic/ecl/build/gmp'
         Makefile:132: recipe for target `libeclgmp.a' failed
         make[1]: *** [libeclgmp.a] Error 2
         make[1]: Leaving directory `/home/Matic/ecl/build'
         Makefile:70: recipe for target `all' failed
         make: *** [all] Error 2

If you want me to try anything else, i'll be glad to help!
I would also like to know, what is needed to build ECL on Windows with 
GNU tools.


On 7.8.2013 18:22, juanjose.garciaripoll at gmail.com wrote:
> Yes, what I have now is Windows 8 64bit, but I installed the 32 bit 
> version of Mingw, because that worked fine in my older images of 
> Windows Server 2008 :-/ That is no longer the case: gmp, boehm-gc and 
> other components from ECL no longer build with mingw32, at least on my 
> computer. I wonder whether I have something misconfigured.
> *De:* Gabriel Dos Reis
> *Enviado el:* ?miércoles?, ?7? de ?agosto? de ?2013 ?14?:?34
> *Para:* Juan Jose Garcia-Ripoll
> *CC:* list-ecl
> On Wed, Aug 7, 2013 at 1:42 AM, Juan Jose Garcia-Ripoll
> <juanjose.garciaripoll at gmail.com> wrote:
> > I am _very_ slowly transitioning all my data and processes to the new
> > Windows computer. Due to the changes in the Windows interface it is much
> > slower tan I anticipated and found a few surprises.
> >
> > One surprise is that GMP does not seem to build at all with the 
> versión of
> > mingw32 I installed. Is there anybody else here with the same problem?
> Are you referring to Windows 8?
> -- Gaby
> ------------------------------------------------------------------------------
> Get 100% visibility into Java/.NET code with AppDynamics Lite!
> It's a free troubleshooting tool designed for production.
> Get down to code-level detail for bottlenecks, with <2% overhead.
> Download for free and get started troubleshooting in minutes.
> http://pubads.g.doubleclick.net/gampad/clk?id=48897031&iu=/4140/ostg.clktrk
> _______________________________________________
> Ecls-list mailing list
> Ecls-list at lists.sourceforge.net
> https://lists.sourceforge.net/lists/listinfo/ecls-list

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://mailman.common-lisp.net/pipermail/ecl-devel/attachments/20130808/67773c96/attachment.html>

More information about the ecl-devel mailing list