[Ecls-list] I need a little help please

Matthew Mondor mm_lists at pulsar-zone.net
Fri Nov 18 01:27:54 UTC 2011

On Thu, 17 Nov 2011 15:45:45 -0800
Paul Bowyer <pbowyer at olynet.com> wrote:

> Running the code with (xapp:main) produces an error:
> Asynchronous ID-CHOICE-ERROR in request 11 (last request was 13)  Code 
> 55.0 [CreateGC] ID #x1
>     [Condition of type XLIB:ID-CHOICE-ERROR]

When I tried CLX (the ECL embedded one, on NetBSD/i686, some time ago),
everything built fine but at execution time I had the same error when
trying to open a window.  I unfortunately had no time to investigate
further (and it wasn't an urgency, I only wanted to experiment with
CLX), but it could be that CLX needs an update to cope with post-XOrg
protocol changes, perhaps, I have no idea.

Most C software would use xlib (or more recently xcb), but CLX talks
the X11 protocol itself over sockets directly, which is why I suspect
CLX might need updates to cope with X11R7+, but it also could be a
simple bug that was overlooked...  I'm not currently familiar enough
with X11R7 to know if it's totally backwards compatible with X11R5 and

It would be nice to debug this further and make it work, as it'd allow
interesting and rather portable basic graphics flexibility without
extra software.

More information about the ecl-devel mailing list