[Ecls-list] fatal: relocation errors on Solaris x86 and OpenSolaris 64-bit.

David Kirkby david.kirkby at onetel.net
Wed Dec 22 01:48:11 UTC 2010

On 21 December 2010 20:19, Juan Jose Garcia-Ripoll
<juanjose.garciaripoll at googlemail.com> wrote:
> Ok, it seems that the problem is in the link flags. I first realized that
> Sun's compiler did not have the problem
> -bash-4.0$ cc -dy -G -z text -o foo.so ../opensolaris/build/libeclgmp.a
> -Bdynamic -lc
> and then tried adding -shared to the GCC flags
> -bash-4.0$ gcc -shared -dy -G -Wl,-ztext -o foo.so
> ../opensolaris/build/libeclgmp.a -Bdynamic -lc
> So it does not suffice the standard shared-library linking flags for Solaris
> (-dy -G), one also has to add GCC's own flag (-shared) to let it link in a
> different C runtime.
> Juanjo

Removing the compiler options

-G -Bdynamic

and replacing with

shared -Wl,-soname,libcliquer.so

solved another text relocation issue in Sage


However, in that case, someone who did not know what they were doing
converted a executable to a shared library, so I would not put too
much weight into this.


More information about the ecl-devel mailing list