[Ecls-list] Help with asdf:make-build and packages

Elliott Slaughter elliottslaughter at gmail.com
Mon Mar 2 08:57:01 UTC 2009


I'm trying to use asdf:make-build to build a system I built using asdf. My
problem is that after the build completes, when I run the executable I
created, none of my packages appear to exist. When I run the program,
find-package returns nil for any package I defined or imported. And if I try
to add an epilogue which calls a function in one of my packages, it fails
saying the function is undefined.

I don't entirely understand what is going wrong, since when I added a
package to the example in /ecl/examples/asdf, the example still worked fine.

How can I determine what the problem might be?

Any advice or assistance would be appreciated. Thanks in advance.

Elliott Slaughter

"Any road followed precisely to its end leads precisely nowhere." - Frank
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://mailman.common-lisp.net/pipermail/ecl-devel/attachments/20090302/6b525062/attachment.html>

More information about the ecl-devel mailing list