[Ecls-list] Embedding question

Juan Jose Garcia-Ripoll jjgarcia at users.sourceforge.net
Thu May 22 16:58:35 UTC 2008

On Thu, May 22, 2008 at 6:17 PM, Robert Dodier <robert.dodier at gmail.com> wrote:
> To avoid pain and suffering, cl_eval should be renamed to cl_unsafe_eval,
> and si_safe_eval renamed to cl_eval.

ECL exports all of the Common Lisp functions with their original
names, so I do not think that would be a fair change. In particular
when si_safe_eval takes other kinds of arguments.

Furthermore, functions with the same names as those in the Common Lisp
package do nothing else than expected from a Common Lisp user. Hence,
eval does not have to capture errors, just like it does not in Common

The thing is that I myself do not use si_safe_eval. The "get all
errors and output just a flag value" approach is only valid for small
projects with few requirements. Instead, I build code that captures
and handles the errors and which do something more when it detects a
nonlocal jump. That code can be written in Lisp, because it is easier
and more future-proof.


Facultad de Fisicas, Universidad Complutense,
Ciudad Universitaria s/n Madrid 28040 (Spain)

More information about the ecl-devel mailing list