[Ecls-list] Mingw build error

Juan Jose Garcia-Ripoll jjgarcia at users.sourceforge.net
Tue Mar 20 17:32:57 UTC 2007

2007/3/12, Marko Kocić <marko.kocic at gmail.com>:
> I tried to build latest CVS using mingw and gmp Makefile is also not generated.
> I tried different variations of
> ./configure --enable-threads --enable-unicode --enable-slow-config
> --with-tcp --with-clx --with-system-gmp=no --prefix=/c/lisp/app/ecl
> but with no luck.

First of all, never use the --enable-slow-config flag. Second, even
without it, GMP will refuse to build. That is a problem with the
library. I am trying to fix it right nw, though it is not really my
work and I am not sure I will succeed.

The problem is that GMP builds programs with an include statement such as

#include "/absolute/path/to/sources/gmp-h.in"

and this path is only valid for mingw, not for gcc. In othe words, the
POSIX paths that msys supports are not supported by their port of GCC.
Simply schizophrenic

> Is mingw port still supported, or we have to switch to MSVC?

The Mingw port is now user supported. I try to commit fixes and
correct things myself, but it has become a pain on the ass as a
platform, quite as much as GMP 4.2.1 is as a library.  The MSVC port
simply works and when it breaks it is rather easy to fix things.
Cygwin is also another viable option right now.


Dpto. de Fisica Teorica I, Fac. de CC Fisicas, Universidad Complutense,
Ciudad Universitaria s/n Madrid 28040 (Spain)

More information about the ecl-devel mailing list