[Ecls-list] OS X Build problem

Juan Jose Garcia-Ripoll jjgarcia at users.sourceforge.net
Sun Dec 10 07:52:09 UTC 2006

2006/12/10, Dustin Long <dlong at stevens.edu>:
> This also fixed the same bug I was getting when building in windows
> under cygwin. With one additional change I can get it to build now:
> int8_t was doubly defined, a patch to fix it is attached.

Ok, I will commit it later.

> I'm still getting an error when trying to build with MSVC++ 6. The lisp
> core boots, then tries to load compile.lsp and crashes when trying to
> (:wants-defsystem ...). It's the same thing that Yaroslav emailed about
> on Nov 14. I realize that you still don't have a windows machine to
> build on, so whenever you can look at it would be fine.

Hmm, this is most puzzling. The situation is as follows. I got my
computer back this week -- power supply was broken -- and reinstalled
Window XP Home SP 2, Cygwin, Mingw and free Microsoft Visual Studio

Out of these programs, Cygwin and Mingw crash _always_, though at
random different points. The situation with Mingw is even worse
because it does not work out of the box: one has to look for a DLL
from some snapshot, but that does not solve the problem: the bash
shell crashes with stack dumps over and over.

I have tried with all possible combinations of mingw, msys and
msys-dtk, and downloaded cygwin from multiple repositories.

MSVC++ on the other hand _did_ build ECL. The process completed using
ECL from CVS. There are warnings about the compiler flags, whose names
have changed, and about "makeinfo" which I do not have in my system
but it worked like a charm. Perhaps I should try with different flags
or build the multithreaded version _yet_, but I am tempted to drop
support for cygiwn/mingw and concentrate on the MSVC version.



Dpto. de Fisica Teorica I, Fac. de CC Fisicas, Universidad Complutense,
Ciudad Universitaria s/n Madrid 2804 (Spain)

More information about the ecl-devel mailing list