[Ecls-list] Problems with ECL in vim

Daniel Trstenjak Daniel.Trstenjak at online.de
Tue Apr 4 11:33:00 UTC 2006

> Do you use the same version? CVS or one of the latest tarballs?

I tried ecl 0.9h and the current cvs with the same result

> There seems to be a problem at initialization time. ECL is reading all
> constant values used by a module and it fails to read some complex
> number. I cannot locate the precise module where this seems to happen,
> because inly the reference to init_LSP is left. Inspecting the data
> section of that module might help identify whether the data is corrupt.

I don't understand exactly what you mean with "Inspecting the data section of that module".
You mean the module LSP ? Where can I find it, and for what should I look ?
Can you please clarify this for me. 

> What I wonder is why cl_boot() was not called before. Does this
> interface wait for the first lisp command to initalize ECL? Or is it
> accidentally calling cl_boot() a second time?

The interface waits for the first lisp command to initalize ECL.

Thanks for the help.


More information about the ecl-devel mailing list