[Ecls-list] MacOSX problems (some solved)

Juan Jose Garcia Ripoll jlr at mpq.mpg.de
Mon May 23 07:06:16 UTC 2005


I have solved some of the problems you reported, at least on the Mac OSX 
10.2 box to which I have access.

The first problem was due to an autoconf variable not being properly 
expanded, so that the library libecl.dylib did not know where it was 
going to be installed. This has been fixed, and at least on the system I 
mentioned before, ECL compiles, builds, installs and runs, being able to 
compile and load modules (such as in (load "cmp.fas"))

Please verify that these patches found in the Sourceforge releases 
webpage, either by downloading the file ecl-0.9f-patch-1.tgz or by using 
CVS to retreive the latest version.

If this still does not work, then it is probably due to issues with the 
Boehm-Weiser garbage collector. I have seen problems reported in the 
mailing list, specially regarding the latest version of Mac OSX (10.4 I 
think, Tiger). It would be nice if you could confirm whether these 
problems appear in your 10.3.9.


-------------- next part --------------
A non-text attachment was scrubbed...
Name: jlr.vcf
Type: text/x-vcard
Size: 361 bytes
Desc: not available
URL: <https://mailman.common-lisp.net/pipermail/ecl-devel/attachments/20050523/b76eb9e4/attachment.vcf>

More information about the ecl-devel mailing list