[Ecls-list] Re: ecls 0.9d not released?

Juan Jose Garcia Ripoll lisp at arrakis.es
Mon Oct 25 09:20:24 UTC 2004

Hi Bernd,

sorry that I copied this message to the mailing list, but it should also 
serve as a public answer for your question.

Bernd Kiefer wrote:

>is there a reason why there is no 0.9d release? I work with
>a newer version for quite a while and the old one simply doesn't do
>the thing because of the old bugs. Is there a problem with the most recent version?
There is no problem in the new version that was not in the previous 
ones. However, I did not want to make a release until I solved a big 
issue. Namely, the lisp->C translator produced wrong code when using 
many nested FLET/LABELs. I finished these fixes, but then again another 
bug has popped up that makes the ANSI test suit crash in my computer 
(*), and I had to delay testing until I solved this.

Furthermore, somehow, ECL no longer compiles under Mac OSX because the 
libtool scripts are broken -- even though I never touched them :-/... 
something must have changed between OSX releases ---. And from other 
messages, it seems that some 64-bit architectures might have problems 
(Solaries does not, so I will have to check on Alpha).

I would like to get this solved before Halloween (a new release, I mean)


(*) I think I found the bug, related to FORMAT not liking bignum 
integers as arguments, so that
    (FORMAT t "~10,-10000000000000000r" "12345")
crashed ECL.

More information about the ecl-devel mailing list