[Ecls-list] Ecls-list digest, Vol 1 #330 - 1 msg

Goffioul Michael goffioul at imec.be
Mon Nov 22 01:32:05 UTC 2004

> But it works ok with ecl-0.9:
> [pascal at thalassa encours]$ /local/src/ecl-0.9/build/ecl
> /local/src/ecl-0.9/build/ecl
> ECL (Embeddable Common-Lisp) 0.9
> Copyright (C) 1984 Taiichi Yuasa and Masami Hagiya
> Copyright (C) 1993 Giuseppe Attardi
> Copyright (C) 2000 Juan J. Garcia-Ripoll
> 	ECL is free software, and you are welcome to redistribute it
> under certain conditions; see file 'Copyright' for details.
> Type :h for Help.  Top level.
> > (load "/home/pascal/src/lisp/encours/readtable-goffioul-test.lisp")
> (load "/home/pascal/src/lisp/encours/readtable-goffioul-test.lisp")
> ;;; Loading 
> "/home/pascal/src/lisp/encours/readtable-goffioul-test.lisp"
> "value1" 
> #P"/home/pascal/src/lisp/encours/readtable-goffioul-test.lisp"
> > $s1
> $s1
> "value1"
> T
> > 
> What version do you use?

I tryied again, using a fresh ECLS CVS version (~0.9d). I just
did some trivial changes to make it compile under Win32/MSVC6
(ecl.h needs to be included after math.h otherwise there's a
problem with the complex macro from MSVC; I doubt this has any
effect on my current problem). It still doesn't work. Loading
the test file runs fine, but the readtable is not changed in
ECLS prompt. Even if I (setf *readtable* *custom-readtable*)
at the prompt, it still doesn't work (cf. previous posts for
full code).
However, if I (eval (read-from-string "$s1")), then it works.
Can anybody confirm (or not) this with 0.9d?


More information about the ecl-devel mailing list