[Ecls-list] alpha-netbsd1.6.1 build failure @ 1st call of ecl_min

Prut Flut prutflut at m-net.arbornet.org
Sat Oct 25 13:18:02 UTC 2003


I'm trying to build ECL on an Alpha running NetBSD in my user
account (ie --prefix=$HOME):
$ uname -a | fmt
NetBSD droog 1.6.1_STABLE NetBSD 1.6.1_STABLE (sdf) #0: Sun Oct 12
04:58:20 UTC 2003     root at ol:/sys/netbsd/arch/alpha/compile/sdf

I downloaded ecl-0.9b.tgz from sourceforge.  I ran into a couple
of problems.  First, the ones I could work around:
- boehm-gc insists on using bash as shell.  However bash does not
  work in my environment (some shared library issue that I cannot
  fix, seen as I am not root).  gmp had the same problem, but that
  could be fixed using "--with-gmp=SHELL=/bin/sh".  So I manually
  fixed the Makefile in build/gc
- The gmp.texi files uses some constructs that the makeinfo
  (GNU texinfo) 4.0 won't recognize: @copy ... @end copy,
  @documentdescription ... @end documentdescription and
  @insertcopy.  I fixed this by putting these lines as comments
  (rather a workaround, I can always ask the maintainer of the
  system to update his texinfo installation).
- also, the system was recognized as unknown-unknown-netbsd1.6.1,
  which leads gmp to not take into account the assembler routines
  in the subdirectory src/gmp/mpn/alpha (ie they are not copied
  to the build/gmp directory), resulting in missing
  __gmp_invert_limb errors.  This problem is worked around by
  specifying "--build=alpha-alpha-netbsd1.6.1"

However: after
./configure --prefix=$HOME/pkg --without-x \
	--build=alpha-alpha-netbsd1.6.1 \
	--with-gmp="SHELL=/bin/sh" SHELL=/bin/sh
(modify build/gc/Makefile to set SHELL=/bin/sh instead of bash)
gmake fails at the first invocation of ecl_min:
	gmake[1]: Entering directory `/arpa/p/pcrama/ecl-0.9b/build'
	if [ -f CROSS-COMPILER ]; then \
		./CROSS-COMPILER < compile.lsp; \
	else \
		./ecl_min < compile.lsp; \
	;*** Lisp core booted ****
	ECLS (Embeddable Common Lisp)  16384 pages

	Unrecoverable error: 
	Lisp initialization error.

	Abort trap - core dumped
	gmake[1]: *** [ecl] Error 134
	gmake[1]: Leaving directory `/arpa/p/pcrama/ecl-0.9b/build'
	gmake: *** [all] Error 2
I tried to run ecl_min myself:
$ build/ecl_min
	;*** Lisp core booted ****
	ECLS (Embeddable Common Lisp)  16384 pages

	> nil
	> t
	> '(1 2 + 4)
	(1 2 + 4)
	> (+ 1 2)

	Unrecoverable error: 
	Lisp initialization error.

	Abort (core dumped) 

I have no idea as to what I should do next to get a working common
lisp on that machine.  Is NetBSD that different from Linux?  Could
it be because NetBSD-stable still uses gcc 2.95.3?

Many thanks for the time you already invested in ecl as well as many
thanks in advance for your help

Philippe Crama
PS: I hope this message won't appear twice on the list.  I sent a
    first copy yesterday (without subscribing to the list), but
    because my message didn't show up, I subscribed 10 minutes ago
    and I resent this message.

More information about the ecl-devel mailing list