[cdr-discuss] Re: [RfC] WITH-READTABLE-ITERATOR
Tobias C. Rittweiler
tcr at freebits.de
Fri Oct 3 15:04:00 UTC 2008
"Tobias C. Rittweiler" writes:
> The variable MACRO-CHAR-TYPES controls which macro characters are returned:
> All macro characters in READTABLE that are _not_ dispatch macro
> All dispatch macro characters in READTABLE.
I'm not perfectly happy with these names. Especially the first one is
somewhat misleading. But I don't think I'd be happy with
But what I wanted to ask is if these names should be in plural perhaps
rather than in singular?
(with-readtable-iterator (next-entry *readtable* :dispatch-macro-chars)
looks better to my eyes than
(with-readtable-iterator (next-entry *readtable* :dispatch-macro-char)
What do you think?
More information about the cdr-discuss