[Asdf-devel] resurrecting some tests

Robert P. Goldman rpgoldman at sift.info
Wed Oct 15 21:05:49 UTC 2014

Dave Cooper wrote:
> For what it's worth, I experimented with my installed clisp (installed
> with homebrew on Mac, clisp 2.49). Just starting the plain clisp, and
> calling 
>   (ext:saveinitmem "/tmp/try.image" :executable t)
> results in an image which gives the same error:
>   module 'syscall' requires package OS. 
> Reading in some forums
> (http://web.archiveorange.com/archive/v/nsNbdc66dCHkCg8lKyXg), other
> people encountered the same error, and fixed it by upgrading to CLISP
> 2.49+.  Will try that when I get a chance...  should we comment out the
> test-program.script for clisp, or assume clisp 2.49+ and leave it in? 
> It seems like it is time to ask the clisp maintainers (if any) to try to
> make new builds, which fix this problem - I for one am not really used
> to hand-compilng Lisps like this... 

The clisp test failure is a failure in the lisp-invocation library. I
don't own that (still waiting for commit privileges), so I made the
executive decision not to hold up ASDF release for it.

I try to keep up on the latest *released* versions of lisp
implementations, and there are some (SBCL, mkcl, and ABCL) where I'm
more likely to be on the bleeding edge. With these exceptions, I limit
myself to testing against versions available through Mac Ports and
Ubuntu packages.  I don't regard it as my job to build or test on
pre-release versions of lisp implementations, although I'm certainly
willing to provide support for those who wish to do so.

Minimakefile is not in master yet, so it's not ready. I hope to work to
get it into master, but I'm not sure how to test it. Since it's a
development tool, it's not obvious how to test it.


> On Wed, Oct 15, 2014 at 1:29 AM, Dave Cooper > wrote:
>     [please let me know if I should post this to the
>     asdf-devel at common-lisp.net  - I'm
>     not sure if we are back in testing mode or not]:
>     So is 3.1.4 the thing we were trying to run these tests for? 
>     It got released with several apparent issues still hanging. Is the
>     idea that those issues are not new regressions, so go ahead and
>     release? 
>     Anyway I'm trying to carry on with some testing here. Currently I get:
>      Macos:
>     ======
>      Master: Failure with clisp (as reported before)
>      Minimakefile: If I run the tests as before, with several
>     ASDF_TEST_LISPS, it only runs for sbcl (and does succeed). 
>      Windows:
>     =======
>      Master: [alisp.dxl] TEST ABORTED: illegal namestring: ... (reported
>     last time)
>      Minimakefile: Makefile:88: *** missing separator (did you mean TAB
>     instead of 8 spaces?). Stop. 
>     -- 
>     My Best,
>     Dave Cooper, Genworks Support
>     david.cooper at genworks.com ,
>     dave.genworks.com (skype)
>     USA: 248-327-3253 (o), 1-248-330-2979
>     (mobile)
> -- 
> My Best,
> Dave Cooper, Genworks Support
> david.cooper at genworks.com ,
> dave.genworks.com (skype)
> USA: 248-327-3253(o), 1-248-330-2979(mobile)
> UK: 0191 645 1699

More information about the asdf-devel mailing list