[Asdf-devel] clisp on Linux [was Re: ASDF Release?]

Faré fahree at gmail.com
Tue Oct 7 17:54:07 UTC 2014

On Tue, Oct 7, 2014 at 12:14 AM, Robert P. Goldman <rpgoldman at sift.info> wrote:
> Here's what I see:
> $ clisp -M
> ../build/fasls/clisp-2.49-unix-x64/asdf/test/hello-world-example--all-system\
> s.image
> /usr/lib/clisp-2.49/base/lisp.run: initialization file
> `../build/fasls/clisp-2.49-unix-x64/asdf/test/hello-world-example--\
> all-systems.image' was not created by this version of CLISP runtime
That's probably clisp not being able to recognize an image it itself
produced if it was made executable. I'd file a bug against clisp if I
cared enough.

> rpg at crypto ~/common-lisp/asdf/test $
> ../build/fasls/clisp-2.49-unix-x64/asdf/test/hello-world-example--all-systems.image
> [1]>
> So it seems that these images can't be run as -M arguments to clisp, but
> they are directly executable.
Yes. ASDF, after cl-launch from which it stole dump-image, creates
executable images on all implementations that allow it (no override
implemented yet — patches welcome I presume), because that can save a
lot of headache wrt to always having to distribute two files
(executable and image) and/or trust the system to always recompile all
images when the implementation is upgraded (something that
common-lisp-controller aimed at doing, but ultimately failed because
the overhead of requiring debian packaging was too high and lispers
wouldn't bother).

> The [1]> prompt is the same as yours, right?  And the [1] is a command
> count. IIUC there are two mysteries:
> 1. when I run the test, why does the output include the prompt, instead
> of being prompt-stripped as it seems to be for you (since the test
> passes for you)? and
> 2. why do I have a command count of 4?
Yes, the [1]> is alright. So my previous hypothesis of an unflushed
buffer with [4]> in it seems debunked. I have no other candidate
explanation for either of these mysteries. Can you trace run-program
and, looking at the command line, tweak it to isolate what causes the

Once again, I cannot reproduce with either the ubuntu 14.04 provided
clisp 2.49 or my compilation of the latest 2.49+ from hg (I tried to
pull: no change since I last compiled). Could your clisp version be at
stake? How recent/old is it? Can you try a recent one?

—♯ƒ • François-René ÐVB Rideau •Reflection&Cybernethics• http://fare.tunes.org
Many who think themselves infinitely superior to the aberrations of Nazism,
and sincerely hate all its manifestations, work at the same time for ideals
whose realisation would lead straight to the abhorred tyranny.
        — F.A. Hayek (1899–1992), 'The Road to Serfdom' (1944)

More information about the asdf-devel mailing list