[Asdf-devel] clisp on Linux [was Re: ASDF Release?]

Robert P. Goldman rpgoldman at sift.info
Tue Oct 7 04:14:58 UTC 2014

Faré wrote:
> On Mon, Oct 6, 2014 at 5:12 PM, Robert P. Goldman <rpgoldman at sift.info> wrote:

> I don't understand how this error comes to be. I tried with the
> ubuntu-provided clisp 2.49 (1:2.49-9ubuntu1) instead of the one I
> custom-built from HEAD a few weeks ago, and it works fine, too. And so
> I can't debug a problem I can't reproduce and can't fathom.
> Can you identify what command is being run? e.g. by tracing
> run-program in test-program.script. How does the dumped clisp
> executable image behave without any of the provided arguments? Is
> there some hidden configuration file that is biting us? Are we failing
> to disable configuration files when calling the image?

Here's what I see:

$ clisp -M
/usr/lib/clisp-2.49/base/lisp.run: initialization file
all-systems.image' was not created by this version of CLISP runtime
rpg at crypto ~/common-lisp/asdf/test $


So it seems that these images can't be run as -M arguments to clisp, but
they are directly executable.

The [1]> prompt is the same as yours, right?  And the [1] is a command
count. IIUC there are two mysteries:
1. when I run the test, why does the output include the prompt, instead
of being prompt-stripped as it seems to be for you (since the test
passes for you)? and
2. why do I have a command count of 4?


More information about the asdf-devel mailing list