[asdf-devel] (asdf:build 'foo)

Faré fahree at gmail.com
Wed Mar 12 18:47:37 UTC 2014

On Wed, Mar 12, 2014 at 2:02 PM, Cyrus Harmon <ch-lisp at bobobeach.com> wrote:
> I would suggest asdf:build-system (or renaming load-system, etc… to load, etc…). Let’s be consistent here.
There is already a build-system. One of the points was to make it
short, since it's going to be used a lot at the command-line, hence
build. Or maybe bs? Or b? Also, since ASDF3, you don't have to build a
*system*, for ASDF will do the right thing if you (asdf:operate
'load-op '("some-system" "some-module" "some-file")), the -system is
misleading. Maybe having the class name also be a function name would
be right?
(asdf:load-op 'foo) (asdf:build-op 'bar)

—♯ƒ • François-René ÐVB Rideau •Reflection&Cybernethics• http://fare.tunes.org
Plug and Pray!

More information about the asdf-devel mailing list