[Asdf-devel] mkcl and asdf upgrade. It works now.

Faré fahree at gmail.com
Wed Jun 18 05:55:54 UTC 2014

Cher JCB,

> The whole fix is in MKCL's git repo master head. I tried it on my copy
> of ASDF syntax-control branch head and it worked OK. Could you
> please confirm that it also works for you?
I ran
cl -l mkcl -ip :ok
which worked with both asdf 3.1.2 and the syntax-control branch,
which is progress as compared to my attempts yesterday or so.

The upgrade test also worked (on the syntax-control branch).

> This will be part of MKCL 1.1.9 that I will push out the door as a released
> version in a few days from now.
> Thank you for your help solving this MKCL's issue.
Can you upgrade your ASDF from to 3.1.2?
Does 3.1.2 require a patch? If it does, then let's get it pushed
upstream into e.g.

NB: please send a diff; I can review it, but Robert should commit and
push it — I'm out of this business (except for the branches I wrote
and would like to see merged — Robert, any news about them?)

PS: minor issue, but when I (quit), I get this annoying message:
> (quit)

;; MKCL shutdown: Thread refused to be interrupted: Sleeping thread:
#<thread "Imported thread pool filler daemon" active detached (27380)
0x7f1aa19d0700 0000000003286000>, in file threads.d at line 1076.
;; MKCL shutdown: Killing thread #<thread "Imported thread pool filler
daemon" active detached (27380) 0x7f1aa19d0700 0000000003286000>.

—♯ƒ • François-René ÐVB Rideau •Reflection&Cybernethics• http://fare.tunes.org
"Ask not what the government can do for you. Ask what the government is doing
to you." — David Friedman, "The Machinery of Freedom", p. 21

More information about the asdf-devel mailing list