[Asdf-devel] mkcl and asdf upgrade. It works now.

Jean-Claude Beaudoin jean.claude.beaudoin at gmail.com
Wed Jun 18 05:34:24 UTC 2014

On Mon, Jun 16, 2014 at 9:20 PM, Faré <fahree at gmail.com> wrote:

> Interestingly, uiop/common-lisp.lisp sets
> clos::*redefine-class-in-place* in uiop/common-lisp — is the problem
> due to your compiling asdf/defsystem separately, and bind r-c-i-p in
> LOAD, so that this setting doesn't apply to asdf/defsystem?

I thought this was one possible problem but obviously this is not the one
you hit upon. (And I believe it still is a loophole worth closing).

> At first, your solution looked like it wasn't working. Then, I tried
> to reproduce, and then it worked against ASDF 3.1.2. But still not
> against the syntax-control branch. I'm confused.
It turns out that I have never taken time to do a complete and detailed
inspection of each and every location in the MKCL's code where
object up-to-date-ness is required, until now that is.  And what you hit
upon, trying to do your ASDF upgrade, revealed a good number of
gaping holes inside MKCL in that area.  So now I hope I have plugged
all of them properly without missing one.

The whole fix is in MKCL's git repo master head. I tried it on my copy
of ASDF syntax-control branch head and it worked OK. Could you
please confirm that it also works for you?

This will be part of MKCL 1.1.9 that I will push out the door as a released
version in a few days from now.

Thank you for your help solving this MKCL's issue.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://mailman.common-lisp.net/pipermail/asdf-devel/attachments/20140618/701fac68/attachment.html>

More information about the asdf-devel mailing list