[asdf-devel] uiop/filesystem:directory-files

Станислав Кондратьев kondratjevsk at gmail.com
Sat Feb 1 20:13:27 UTC 2014


I tried uiop and discovered two issues.

I had installed uiop using quicklisp.

The first issue looks like a bug: if I list the files of my home directory
in CLISP, every file is included in the list twice as if the directory were
listed two times.  This takes place no matter if I specify the directory as
"~/" or spell it out, and also if I run CLISP in my home directory and use
uiop/os:getcwd.  However, the function works normally with directories
other than the home one.  I did not specify wildcards in either case.  I
have observed this behaviour on Debian and OpenSuse.

The second issue looks like a discrepancy between implementations: while in
CLISP uiop/filesystem:directory-files returns a list of files (not
subdirectories), in SBCL the directories are included into the output.  I
wonder at least which behaviour is the intended one.

Best regards,
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://mailman.common-lisp.net/pipermail/asdf-devel/attachments/20140201/7139a18c/attachment.html>

More information about the asdf-devel mailing list