[asdf-devel] uiop/filesystem:directory-files

Faré fahree at gmail.com
Sun Feb 2 00:18:30 UTC 2014

It's a bug indeed. Unhappily, DIRECTORY is not portable at all. I've
added an ugly workaround in
If you're volunteering to commit a real fix, and tests, to make sure
it works on each and every of the 10+ supported implementations,
together with a regression test, I'll be delighted to commit it.

—♯ƒ • François-René ÐVB Rideau •Reflection&Cybernethics• http://fare.tunes.org
The urge to save humanity is almost always a false front for the urge to rule.
        — H. L. Mencken

On Sat, Feb 1, 2014 at 3:13 PM, Станислав Кондратьев
<kondratjevsk at gmail.com> wrote:
> Hello,
> I tried uiop and discovered two issues.
> I had installed uiop using quicklisp.
> The first issue looks like a bug: if I list the files of my home directory
> in CLISP, every file is included in the list twice as if the directory were
> listed two times.  This takes place no matter if I specify the directory as
> "~/" or spell it out, and also if I run CLISP in my home directory and use
> uiop/os:getcwd.  However, the function works normally with directories other
> than the home one.  I did not specify wildcards in either case.  I have
> observed this behaviour on Debian and OpenSuse.
> The second issue looks like a discrepancy between implementations: while in
> CLISP uiop/filesystem:directory-files returns a list of files (not
> subdirectories), in SBCL the directories are included into the output.  I
> wonder at least which behaviour is the intended one.
> Best regards,
> Stanislav.

More information about the asdf-devel mailing list