[asdf-devel] prepare-op

Faré fahree at gmail.com
Tue Dec 18 18:20:51 UTC 2012

On Tue, Dec 18, 2012 at 12:01 PM, Zach Beane <xach at xach.com> wrote:
> Faré <fahree at gmail.com> writes:
>> sb-md5 hasn't been modified in years, but it depends on sb-rotate-byte
>> which was just tweaked because of :if-component-dep-fails.
>> ASDF used to not propagate timestamps from system to system,
>> or from .asd file to the system internals, but now it does both,
>> and so the change in sb-rotate-byte.asd now causes sb-md5
>> to be out of date.
>> stassats tells me SBCL usually does a clean.sh as the first thing in make.sh,
>> so if you built with make.sh instead of slam.sh, and didn't update your
>> source in between make.sh and install.sh, there should be not have
>> been an issue.
> Ok, I updated to the latest SBCL sources, did this:
>   sh clean.sh
>   sh make.sh
>   sudo sh install.sh
> Then I change to the ASDF directory and do this:
>   sbcl --non-interactive --no-userinit --load asdf.lisp --eval "(require :sb-md5)"
> I still get the permission error.
> Did I miss a step?
No, you're not missing anything. That's weird: I tried, and it worked for me.

Can you attach a trace of this?

(trace asdf::visit-action asdf::compute-action-stamp
asdf::safe-file-write-date) (asdf:traverse (make-instance
'asdf:load-op) (asdf:find-system :sb-md5))

—♯ƒ • François-René ÐVB Rideau •Reflection&Cybernethics• http://fare.tunes.org
It should be a grammatical if not legal offense to ascribe thoughts,
opinions and decisions to "we" without a signed power of attorney.

More information about the asdf-devel mailing list