Bug in path handling on 1.3.2

Timo Myyrä timo.myyra at wickedbsd.net
Sun May 3 10:20:21 UTC 2015

Mark Evenson <evenson at panix.com> writes:

> On 2015/5/3 07:48, Timo Myyrä wrote:
>>>> Just tried to update ABCL to 1.3.2 but got error when I tried to load
>>>> hunchentoot. The actual error case can reduced to this:
>>>> (DIRECTORY #P"/usr/local/bin/../lib/maven-core-*.jar")
>>>> I tried above with sbcl, ecl and clisp. All those return nil as result.
>>>> With ABCL I get:
>>>> Bad place for a wild pathname.
>>>>    [Condition of type FILE-ERROR]
> […]
>> But I looked a bit further into this and noticed that issue seems to only affect
>> OpenBSD-current I run on my laptop.  When I evaluated `(DIRECTORY #P"/usr/local/bin/../lib/maven-core-*.jar")' 
>> with ABCL 1.3.2 on my OpenBSD 5.6 server, it returns nil. 
>> After updating my server to 5.7 and rebuilding ABCL, it still returns nil.
>> I'm a bit curious why my laptop running OpenBSD-current behaves differently.
>> I tried to manually build the ABCL from the source distribution without using
>> OpenBSD ports framework and I still hit the issue.
>> Here's the lisp implementation, its same on 5.7 and -current.
>> "1.3.2"
>> "OpenJDK_64-Bit_Server_VM-Oracle_Corporation-1.7.0_71-b14"
>> "amd64-OpenBSD-5.7"
>> CL-USER(4): 
> […]
> Indeed mysterious, but at least there is a potential difference in that
> you are encountering the difference between OpenBSD 5.7 and CURRENT
> (although now that CURRENT has become 5.7, we'd have to examine your
> local notion of CURRENT.)  If you have the time, you could build another
> CURRENT instance from the same source to see if you can duplicate the
> error on a machine (or virtualization instance) other than your laptop.
>  But that is probably more effort than the problem warrants.
> Wild-assed-guess:  does the argument you are passing to DIRECTORY fail
> to exist on both machines from the view of the kernel?  i.e. from a
> shell with globbing, does
> 	openbsd$ ls -l /usr/local/bin/../lib/maven-core-*.jar
> return no results on all your machines?

Actually I tested the ABCL with my desktop after upgrading it to latest
snapshot. And ABCL worked just fine on it so the problem seems to exist only on
my laptop. I tried the 'ls -l ...' command and my laptop and server both return
"no such file or directory".

I'll continue to see whats causing the problems on my laptop but it seems to
related to some local configuration I have.
Though I don't know what it could be. I have .abclrc but it just loads quicklisp. I checked
I don't have any quicklisp local-projects (had old cffi version but I deleted
it), I removed ~/.cache/common-lisp/* directories. I also upgraded quicklisp and
quicklisp dists to latest versions. I don't know what else could affect it on my


More information about the armedbear-devel mailing list