Bug in path handling on 1.3.2

Timo Myyrä timo.myyra at wickedbsd.net
Sun May 3 05:48:13 UTC 2015

Ville Voutilainen <ville.voutilainen at gmail.com> writes:

> On 29 April 2015 at 23:23, Timo Myyrä <timo.myyra at wickedbsd.net> wrote:
>> Hi,
>> Just tried to update ABCL to 1.3.2 but got error when I tried to load
>> hunchentoot. The actual error case can reduced to this:
>> (DIRECTORY #P"/usr/local/bin/../lib/maven-core-*.jar")
>> I tried above with sbcl, ecl and clisp. All those return nil as result.
>> With ABCL I get:
>> Bad place for a wild pathname.
>>    [Condition of type FILE-ERROR]
> Ok, the diagnostic is overly-strict, because the NAME component should
> be interpreted
> as a string, as it's not a wildcard component. But, I trust you are
> aware that an ANSI
> Common Lisp implementation doesn't necessarily support wildcard-globbing of
> files? SBCL does, so perhaps we should add such an extension to abcl as well.

Sorry for slow response, got little mail server issues.

I'm not that familiar with how ANSI CL should work in these cases so I just
compare each oddity how other implementations handle them. 

But I looked a bit further into this and noticed that issue seems to only affect
OpenBSD-current I run on my laptop.  When I evaluated `(DIRECTORY #P"/usr/local/bin/../lib/maven-core-*.jar")' 
with ABCL 1.3.2 on my OpenBSD 5.6 server, it returns nil. 
After updating my server to 5.7 and rebuilding ABCL, it still returns nil.

I'm a bit curious why my laptop running OpenBSD-current behaves differently.
I tried to manually build the ABCL from the source distribution without using
OpenBSD ports framework and I still hit the issue.

Here's the lisp implementation, its same on 5.7 and -current.

Here's package info if its relevant:
$ pkg_info jdk


More information about the armedbear-devel mailing list