Bug in path handling on 1.3.2

Mark Evenson evenson at panix.com
Wed Apr 29 21:30:22 UTC 2015

On 2015/4/29 22:23, Timo Myyrä wrote:
> Hi,
> Just tried to update ABCL to 1.3.2 but got error when I tried to load
> hunchentoot. The actual error case can reduced to this:
> (DIRECTORY #P"/usr/local/bin/../lib/maven-core-*.jar")
> I tried above with sbcl, ecl and clisp. All those return nil as result.
> With ABCL I get:
> Bad place for a wild pathname.
>    [Condition of type FILE-ERROR]
> Restarts:
>  0: [RETRY] Retry SLIME REPL evaluation request.
>  1: [*ABORT] Return to SLIME's top level.
>  2: [ABORT] Abort thread.


Hmmm.  I can't reproduce your error locally.  What are the values for

@Ville:  can you reproduce this error?

illin:~/work/abcl-bin-1.3.2$ ls /usr/local/bin/../lib
ls: /usr/local/bin/../lib: No such file or directory
illin:~/work/abcl-bin-1.3.2$ java -jar abcl.jar --noinit
Armed Bear Common Lisp 1.3.2
Java 1.8.0_40 Oracle Corporation
Java HotSpot(TM) 64-Bit Server VM
Low-level initialization completed in 0.223 seconds.
Startup completed in 0.897 seconds.
Type ":help" for a list of available commands.
CL-USER(1): (DIRECTORY #P"/usr/local/bin/../lib/maven-core-*.jar")
CL-USER(2): (lisp-implementation-version)

"A screaming comes across the sky.  It has happened before, but there
is nothing to compare to it now."

More information about the armedbear-devel mailing list