[armedbear-devel] RfC: Renaming LispObject.writeToString() to LispObject.printObject()

Erik Huelsmann ehuels at gmail.com
Thu Jul 14 18:42:22 UTC 2011

Yesterday, we fixed #154 -- the PRINT-OBJECT regression in 0.26.0. Once
again, it turns out that our object printing and stringification routines
are confusingly named. Additionally, they are also under documented: The
writeToString() method calls toString(), but doesn't document the difference
between the two.

My idea would be to disambiguate the two functions by making writeToString()
a java-side PRINT-OBJECT, renaming it to printObject() and documenting
that's what it does. Then, probably, the lisp side function %write-to-string
should be renamed to %print-object too. Probably, more adjustments are
required throughout the code base, but those are probably at the
'implementation detail' level.

So, what's your take on it?


-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://mailman.common-lisp.net/pipermail/armedbear-devel/attachments/20110714/3c34ae0d/attachment.html>

More information about the armedbear-devel mailing list