[armedbear-devel] Infinite loop loading compiled file

Alessio Stalla alessiostalla at gmail.com
Tue Jan 25 15:33:58 UTC 2011

On Tue, Jan 25, 2011 at 3:33 PM, Greg Baryza <baryza at intersystems.com> wrote:
> I recently became interested in the language QI.  Since it did not run on
> ABCL (it does on SBCL, Allegro, LispWorks and others), I decided to see
> what it would take to move it there.  From the QI mailing list, I found
> several others had tried on earlier versions of ABCL with inconclusive
> results.  I decided to give it a try on 0.23.1.
> When I tried the standard script with compiles and then loads the compiled
> files, ABCL hangs it what appears to be an infinite loop try to load one of
> the compiled files.  When I switch to just loading them in as Lisp sources,
> things seem to work (though some of the QI tests later fail).
> I tried the compile/load script under 0.24.0 today and the same hang happens.
> I have a small test case consisting only of the needed sources and a couple
> of .bat files for Windows that demonstrates the problem, but before I
> proceed further, has anyone seem anything like this.  The file in question
> DEFUNs about 85 functions.  Is that too many to provoke the "large file"
> problem I see mentioned here?

I ported Qi II to ABCL some time ago (a year?). IIRC it needed some
tweaking related to its (mis)use of the reader. I submitted the patch
to the Qi mailing list, but I don't know if it ever got applied, or if
it diverged since - I'm not a Qi user, I ported it just to get ABCL a
little publicity ;)

0.24 doesn't have the "large file" problem anymore, and anyway "large"
meant many more than 85 functions.

I'm not aware of any problem causing infinite loops when loading compiled files.


More information about the armedbear-devel mailing list