[armedbear-devel] Infinite loop loading compiled file

Greg Baryza baryza at intersystems.com
Tue Jan 25 14:33:06 UTC 2011

I recently became interested in the language QI.  Since it did not run on 
ABCL (it does on SBCL, Allegro, LispWorks and others), I decided to see 
what it would take to move it there.  From the QI mailing list, I found 
several others had tried on earlier versions of ABCL with inconclusive 
results.  I decided to give it a try on 0.23.1.

When I tried the standard script with compiles and then loads the compiled 
files, ABCL hangs it what appears to be an infinite loop try to load one of 
the compiled files.  When I switch to just loading them in as Lisp sources, 
things seem to work (though some of the QI tests later fail).

I tried the compile/load script under 0.24.0 today and the same hang happens.

I have a small test case consisting only of the needed sources and a couple 
of .bat files for Windows that demonstrates the problem, but before I 
proceed further, has anyone seem anything like this.  The file in question 
DEFUNs about 85 functions.  Is that too many to provoke the "large file" 
problem I see mentioned here?


More information about the armedbear-devel mailing list