[armedbear-devel] r12666 breaks ASDF compilation on Linux

Alessio Stalla alessiostalla at gmail.com
Mon May 31 07:08:22 UTC 2010

On Mon, May 31, 2010 at 7:52 AM, Mark Evenson <evenson at panix.com> wrote:
> On 5/28/10 9:36 PM, Alessio Stalla wrote:
>> I just tried abcl 0.20 with Snow, and compilation (done with
>> asdf:compile-op) fails early with:
>> Compilation failed: Not an absolute pathname
>> #P"\\___jar___file___root___\\**\\*.*"
>> r11664 works fine. Sorry that I didn't check before the release, I
>> remembered checking it not much time ago but evidently I was wrong
>> (r12666 is two weeks old).
> I broke my wrist last Thursday, just getting back from the hospital, so
> getting to the bottom of this is going to be slow on my part.

Oh, I'm sorry for you! I hope you recover quickly.

> You say that this is "on Linux" that this fails, yet your Pathname looks
> like a Windows one.  Do you really get the error you pasted from trying to
> ASDF compile Snow on Linux?

Yes, absolutely. I do all my development on Linux.

I didn't study the problem at all, I just verified that with the
previous revision of asdf.lisp it worked. Since r12666 is a single,
small diff, I can try fixing it myself - probably it's just a wrong
conditional clause.

Take care,

More information about the armedbear-devel mailing list