[armedbear-devel] No :DARWIN, "No tag" & no ASDF

John Pallister john at synchromesh.com
Mon Oct 5 20:36:53 UTC 2009

On Mon, Oct 5, 2009 at 9:21 PM, Erik Huelsmann <ehuels at gmail.com> wrote:
> I fixed it in Lisp.java, which sets up *FEATURES* and I fixed it in
> Utilities.java, which indicates the platform type. Fix committed
> already, but please test!

You beat me to it... ;) But I've attached my patch anyway (just for
the practice). You're right, it's a pretty trivial fix. I've tested
it, and it does seem to work. Please let me know if there's anything
wrong with my patch.

> This change is too small (if it works - I don't have darwin) to open
> an issue for. However, if you have patches, please don't hesitate to
> send them.

It's not so much Darwin per se, just my use of the OpenJDK 6 VM

> Shall I contact the c-l.net admins for an account so you can log into
> the bug database yourself?

That would be great, I'd appreciate that. "synchromesh" is my
preferred username, but anything is fine.


John :^P
John Pallister
john at synchromesh.com
john at johnp.net
-------------- next part --------------
A non-text attachment was scrubbed...
Name: osname-darwin-patch.diff
Type: application/octet-stream
Size: 1271 bytes
Desc: not available
URL: <https://mailman.common-lisp.net/pipermail/armedbear-devel/attachments/20091005/4079af54/attachment.obj>

More information about the armedbear-devel mailing list