[armedbear-devel] abcl 0.17 & slime 1:20080223-2

Tobias C. Rittweiler tcr at freebits.de
Fri Dec 11 18:29:54 UTC 2009

Durward McDonell writes:

> Hello.
> I have been trying to get abcl to run under slime, and I have
> hit the limits of my understanding of all the relevant components.
> This is on Ubuntu Jaunty (9.04), with abcl 0.17.0 and slime
> 1:20080223-2.
> The symptom is that slime starts to load, then quits with the
> error "Package "CLC" not found."  I tracked this down to
> swank-loader: binary-pathname calls clc:calculate-fasl-root.
> I've tried everything I could think of, like loading
> clc from my .abclrc, but I could not trick it into loading.
> This must be a solved problem, but I have not been able to
> find anything on the web.

Do not use the Debian/Ubuntu package of Slime. Instead checkout from CVS
directly. (Or use clbuild.)


PS. Before going the CVS/clbuild route, make sure to _purge_ the Slime
Debian package (as well as the (cl-)swank package.)

More information about the armedbear-devel mailing list