[armedbear-devel] abcl 0.17 & slime 1:20080223-2

Durward McDonell durward.mcdonell at jhuapl.edu
Fri Dec 11 18:09:10 UTC 2009


I have been trying to get abcl to run under slime, and I have
hit the limits of my understanding of all the relevant components.
This is on Ubuntu Jaunty (9.04), with abcl 0.17.0 and slime

The symptom is that slime starts to load, then quits with the
error "Package "CLC" not found."  I tracked this down to
swank-loader: binary-pathname calls clc:calculate-fasl-root.
I've tried everything I could think of, like loading
clc from my .abclrc, but I could not trick it into loading.
This must be a solved problem, but I have not been able to
find anything on the web.

On a tangentially related note, in doing all this I discovered
that asdf integrates with sbcl specially, in a way that makes
it a little bit easier to load packages.  Is there a way to get
abcl to look in more than one directory for (load "foo.lisp")?


Durward McDonell
durward.mcdonell at jhuapl.edu

More information about the armedbear-devel mailing list