[slime-devel] New to lisp and slime

Paul Bowyer pbowyer at olynet.com
Wed Mar 30 21:53:35 UTC 2011

On 03/30/2011 11:56 AM, Carlos Konstanski wrote:
> On 03/30/2011 12:37 PM, Paul Bowyer wrote:
>> slime-devel:
>> I'm just learning how to work with lisp and slime and I would like to
>> know if I can ask questions on this list regarding the setup and
>> operation of slime?
>> Thanks,
>> pbowyer
> Of course! Where else can you go for help? Nowhere I can think of.
> Welcome to the rarefied contingent of Lisp programmers! Makes my day.
> Carlos
> _______________________________________________
> slime-devel site list
> slime-devel at common-lisp.net
> http://common-lisp.net/mailman/listinfo/slime-devel
OK then:

In my learning exercises, I have been using something like:
(eval-when (:compile-toplevel :load-toplevel :execute)
   (if (find-package "CH16")
       (delete-package "CH16"))
(defpackage "CH16"
     (:use "COMMON-LISP" "UTIL")
   (:shadow "LENGTH" "MEMBER" "COUNT")
   (:export "LENGTH" "MEMBER" "BEFORE"
             "NUMBER-LISTP" "SAME-LENGTH1"
             "SAME-LENGTH2" "COUNT")

(in-package "CH16")

;;;more code containing functions follows ...
at the beginning of my lisp source files to try to handle problems I was 
having with error messages when I tried to compile or compile/load my 
source. It took me a while to discern how to get this far, but now with 
the code above (after the initial compile/load) I need to compile twice 
or compile then compile/load because the first compile produces error 
messages similar to the following.
Unable to display error condition: *PACKAGE* can't be a deleted package:
   *PACKAGE* has been reset to #<PACKAGE "COMMON-LISP-USER">.
    [Condition of type SIMPLE-TYPE-ERROR]
If I abort to slime's top level and then immediately compile or 
compile/load, it works correctly until the next time I try to compile 
when I have to repeat the process. Is there a way to avoid having to 
repeat the compile process twice? I've tried various gyrations of the 
above code without success.

Before I discerned that I needed to compile twice before getting a 
successful compilation, after aborting to slime's top level I tried 
(find-package "CH16") in the REPL and got NIL. After the second 
compilation, the 'find-package' command succeeded with #<PACKAGE "CH16">.

I'm using:
slime version uncertain, but downloaded recently
All running under PCLinuxOS-2010 using KDE-4.6.1

Thanks for any light you can shed on this,


More information about the slime-devel mailing list