[slime-devel] Re: CLISP SLIME implementation breaks in CVS

funkyj at gmail.com funkyj at gmail.com
Sat Jan 21 03:40:13 UTC 2006

I have since given another 30 minutes to wrestling with the SLIME
install and this time I appear to have won.  Here is the trap I finally

(1) download the 1.2.1 and gave it a try with cygwin clisp 2.35.
    it failed.
(2) followed the "get the latest from CVS" advice.  That failed.
(3) tried "get the FAIRLY-STABLE" tagged version.  That failed.

I went back to the CVS HEAD version did one extra step and voila, it
worked.  Can you guess what that extra step was?

page down for the answer


Apparently you need to delete the "~/.slime/" directory if you change
versions of slime.

It would be nice if slime/emacs could notice that I'm getting ALL my
slime files (.lisp and .el) from a different directory than last time
and either blow away the old .slime/ directory or perhaps ask me if I
want to do this.

Alternatively, slime.info, PROBLEMS or README might mention this.

What pushed me to give SLIME a try again was that I had a problem with
ILISP and when I went looking for the ILISP community it looked like it
has been dead since 2002 or 2003 :^).


More information about the slime-devel mailing list