[slime-devel] Trying to get started with OpenMCL

rif rif at MIT.EDU
Fri Feb 25 19:54:40 UTC 2005

I downloaded the latest OpenMCL distribution for OS x
(openmcl-darwinppc-all-0.14.2-p1.tar.gz) and a fresh CVS slime.  I
tried to start slime with M-x slime from an emacs with a .emacs
containing only:

(setq inferior-lisp-program "/Applications/ccl/scripts/openmcl")
(add-to-list 'load-path "/Users/rif/Software/slime")
(require 'slime)

When I ran M-x slime, I got the following:

(load "/Users/rif/Software/slime/swank-loader.lisp" :verbose t)
(swank:start-server "/tmp/slime.10272" :external-format :iso-latin-1-unix)
Welcome to OpenMCL Version (Beta: Darwin) 0.14.2-p1!
? ;Loading #P"/Users/rif/Software/slime/swank-loader.lisp"...
;Loading #P"/Users/rif/.slime/fasl/openmcl/swank-backend.dfsl"...
;Loading #P"/Users/rif/.slime/fasl/openmcl/nregex.dfsl"...
;Loading #P"/Users/rif/.slime/fasl/openmcl/metering.dfsl"...
;Compiling "/Users/rif/Software/slime/swank-openmcl.lisp"...
;Compiler warnings for "/Users/rif/Software/slime/swank-openmcl.lisp" :
;   Unused lexical variable STREAM, in (MAKE-STREAM-INTERACTIVE (T)).
; Warning: Interface file #4P"ccl:darwin-headers;libc;functions.cdb" does not exist.
; While executing: CCL::CDB-OPEN
Read error between positions 8480 and 8595 in /Users/rif/Software/slime/swank-openmcl.lisp.
> Error in process listener(1): Foreign function not found: OS::|tmpnam|
> Type :POP to abort.
Type :? for other options.
1 > 

Any suggestions?



More information about the slime-devel mailing list